iWitness V1 & V2 to iWitness V3 Upgrade



Existing licensed customers of iWitness V1 and V2 can now purchase the iWitness V3 upgrade for $495.00 (V1) and $395.00 (V2).


Steps to Upgrade:

NOTE: If you are not sure which version of the license you own, just run the program and it will identify which version (i.e. V1 or V2) upon launching the application. It is important to identify the proper Version (V1 or V2) for the upgrade process to work successfully.

1. Purchase the upgrade on our Order Page.

2. Run this executable file with your iWitness USB dongle installed on your computer: DongleUpgrader_toV3.exe (3.01Mb) The screen will look like this, once you download and execute it:


3. You must provide us via email, the Dongle Number after clicking the dialog box Step 2) "READ" button.

4) DCS will email you the Step 4) "activation number" and the iWitness V3 installer (link), which you will need to "install over the top" of iWitness V1.xx.

5) Cut & Paste the activiation number and insert in the Step 4) box, and then click "UPGRADE" in Step 5).

The license has now been updated to iWitness V3.



Notable improvements to versions: iWitness V3 & iWitnessPRO V3




- Increased support up to 1000 images per network - however, it is recommended that iWitness networks are limited to 300 images due to processing time


- Double-click list in 3D Point Information dialog to open images


- Ability to use constructed points for 3-2-1


- Scan for red targets in iWitness


- iWitness can now 'Autocal' via 16 red retro-reflective codes (PMXRED1 to PMXRED16)


- Planar rectification feature (to Z=0) via image right-click menu


- Updated Project Settings dialog


- Hover tool tip for blue predicted points


- Hover tool tip for blue constructed points


- Can now measure distance between a selected constructed point & selected photogrammetry point


- Option for 1, 4, 6, 9 images in Review mode


- Global Camera DataBase (GCDB) updated in early 2013 with recently released camera models


- Improved stability for textures & polylines


- Improved thumbnail popup window


- Import scale & 3-2-1 from another project to apply scale & coordinate transformation


- Code bits can now be optionally left out of the DXF export process


- Information dialog for constructed points can be selected by highlighting and selecting the "P-key" or from double clicking in the 3D List


- Open all images that sees the specific constructed point selected, can now be tiled in the workspace


- Support for codes up to max 981 (previously max 165) (iWitnessPRO)


- Code offset database (iWitnessPRO)


- Code linkers (166-299) for project linking (iWitnessPRO)


- Support for new smaller code size using 5.8mm targets (iWitnessPRO)



- Min rays automatically lowered if a small number of images imported (iWitnessPRO)


- Ability to decode codes placed closer together (iWitnessPRO)


- The 3-2-1 can now be chosen with the use of construction points or 3D object points (iWitnessPRO)


- iWitnessPRO will now automatically link up to 12 networks via common LINKER CODES, shared between each "linked" networks, using codes 166-299 (iWitnessPRO)


- 5.8mm and 7.91mm codes can be used in same network, with one of the two sizes permitted for code offsets (iWitnessPRO)


- Code magic database interface - used to create offset points (a.k.a. constructed points) so both 5.8mm and 7.91mm codes can be used as targets (iWitnessPRO)


- Faster processing for iWitnessPRO (iWitnessPRO)


- O key to force triplet offset target & code offset (iWitnessPRO)


- O key" constructed point generated from 3" spaced "dual" targets, creating a 2.8" offset point to the tip of the target (iWitnessPRO)


- Increased bundle "OFF" support (iWitnessPRO)


- Zoom-dependent (ZD) calibration (iWitnessPRO)


- Various best fit shapes (iWitnessPRO)


- Triangulate All feature (iWitnessPRO)


- Code magic database interface - used to create offset points (a.k.a. constructed points) so either 5.8mm and 7.91mm codes can be used as targets (iWitnessPRO)


- Code bits can now Default off for Edit Review, and optionally turned on in Project Settings


- Improvements to offset points as they appear in the DXF output file

- Information for 3D Point dialog: ability to copy XYZ coordinates to Clipboard


- Added Tutorial Videos on the iWitness/iWitnessPRO DVD (Project Linking and Code Offset Database)


- Ability to unreferenced from the "Information from 3D Point Dialog" (right click feature)


- Code Pointers ranging in code numbers #300 to 399 as 5.8mm dot configuration


- PMX codes now default Off in Project Settings for use in Edit/Review mode



Notable improvements in Version 2.2



- Save/load project improved stability, bug fixes, speed enhancements

- Ability to export .txt format in project linking

- 1/2 keys in Edit/Review mode to drive to previous & next points

-New miscellaneous options in the Project Settings dialog box

- Warning dialog presented if 3-2-1 or set scale is attempted during referencing mode




iWitness V2




Upgrade notes for iWitness: V1.08 to V2.0

The upgrade for iWitness Version 2.0 is a paid upgrade and downloadable by licensed users of V1.08 to V1.5.1 After downloading the 32 mb file iWitness V2.0, double click on this to install the upgrade. The upgrade should be installed ‘over the top’ of the existing iWitness. It is not necessary to remove or save any iWitness files, program or data. The installation will have no impact on your existing iWitness projects.

The following enhancements were made in iWitness Version 2.0:

  • KML export for Google Earth.

  • Point centroiding mode.

  • Image scanning of red targets and associated "driveback" feature.

  • Line Connecting to 3D object points and Offset Points – DXF exportable.

  • Updated image scanning dialog, for greater control over automation.

  • Ability to reference an image with the 3D view, rather than image-to-image only.

  • New popup information in image thumbnails, also for blue predicted points.

  • Ability to manually enter 3D coordinates into a network, one-by-one or from a file.

  • Ability to print out the list of program hot-keys.

  • XYRectify provided free of charge with iWitness V2.

  • Zaraf provided free of charge with iWitness V2.

  • Ability to launch both XYRectify & Zaraf from within iWitness.

  • Updated "Global Camera Database" to support the latest digital cameras.

  • Greater flexibility over what to display in the 3D view.

  • Ability to flatten to Z=0 plane for DXF output.

  • Improvements to program status bar to help monitor photogrammetric network strength, etc.

  • New safety mechanism in place to stop user referencing between two un-oriented images, in a network where oriented images exist.

  • Triplet offset targets (iWitnessPRO only).

  • Numerous bug fixes, improvements to program stability and speed increases across the board.


The following enhancements were made in iWitness Version 1.5.1:

  • Improvements to the B&W passive code feature for camera calibration.
  • Thumbnail files (.thumbnail3) now stored in folder sub-directory.
  • Right-click menu option to access information dialog for a selected 3D point.

The following enhancements were made in iWitness Version 1.5:

  • B&W passive codes for camera calibration, accessed via the Project Settings dialog. Provides automatic calibration via printed codes.
  • Automated network stitching, accessed via "Import projects for linking" under the File menu.
  • XYRectify & Zaraf (located on the CD) are now free to iWitness users and can be launched from the File menu in iWitness. These programs are provided on the iWitness CD.
  • New menu choice to open the current working folder, accessed via Window | "Open Working Folder."

The following enhancements were made in iWitness Version 1.4.4:

  • 3D point merge feature - a fix for when multiple 3D points are accidentally measured in the same location. iWitness automatically warns the operator to correct the user error of "multiple point IDs" sharing the same 3D point in space.

The following enhancements were made in iWitness Version 1.4.3:

  • Software DLLs are automatically installed as part of normal installation procedure.
  • Note that "User Account Control" (UAC) must be switched OFF in Windows Vista for the image thumbnail popup feature to work. See our FAQs, for accomplishing this task.
  • Improvements to points, lines and labels display in 3D view relating to Vista users.

The following enhancement was made in iWitness Version 1.4.2:

  • New drivers added to C:\Program Files\iWitness to resolve installation issues with Windows Vista. See FAQ's for more details.

The following enhancements were made in iWitness Version 1.4.1:

  • Help Menu, Registration field removed.
  • New cameras added to the global camera database.

The following enhancements were made in iWitness Version 1.4:

  • After installation see C:\Program Files\iWitness\docs\iWitness Updates.pdf.
  • 115 new cameras were added to the Global Camera Database.
  • Z-offset coordinates now display in the 3D Points list.
  • Ability to export point coordinates in comma-separated value format (.csv).
  • Automatic 'best partner for image referencing' feature.
  • Results dialog for 'orient all camera stations'.
  • Ability to transform network into independent camera station coordinate system.
  • A warning message for unselecting a single 3D point in both the image and 3D views.
  • Single image orientation and FOOM (Focal length frOm One iMage), by which single images can be oriented and image orientation plus camera calibration can be achieved from a single image and 3D control points.
  • A few bug fixes were implemented regarding the projected blue epipolar line and also an occasionaly zoom window 'hang' if the user had Referenced wrongly.

The following enhancements were made in iWitness Version 1.3:

  • The use of ‘distortion grids’ to visually display the extent of image deformation due to radial and decentering distortion.
  • Resetting the default setting for show/hide images to off. This speeds up the 3D View. The display of images on the back of the camera icons can still be toggled on and off as before.
  • A warning message is now displayed to the operator in situations where the need for PC memory is close to the allowable limit. This allows the operator to close other programs and potentially free up more memory. iWitness will still run in circumstances where the amount of memory requested exceeds that available, but the program may slow down significantly in such circumstances. The most common operation where this situation may be encountered is when calling Edit/Review mode with very large images, eg >10mb each.
  • An issue of line snapping to 3D points has been fixed.
  • Green arrows now appear in the tool bar, to advance (or revisit) the images, sequentially, in the workspace.
  • The Global Camera Database has been updated such that it now comprises an extra 100 or so recently released digital cameras.
  • The Enable/Disable Image function has been removed, since this can be achieved via the Set Un-oriented and Orient Camera Station options, or by removing an image from the project via the Import Images…dialog.
  • The right click option of the 3D view graphics view now displays "Show / Hide Codes", which is reserved for a future version release.
  • The tool bar now displays a "gray box" adjacent the "R+" tool, which is reserved for a future version release.

The following enhancements were made in iWitness Version 1.2.3:

  • Auto-backup .iwp files into subdirectory called 'BACKUPS' under the working directory.
  • Thumbnail Preview windows are improved. Now an option to turn on/off in Preference Settings (Edit Menu + Project Settings.)
  • Line tool has been improved in workspace images and 3D Graphics View.
  • An issue in Polyline mode causing a 'crash' has been fixed.
  • Install issues (required dll's) for Windows 2000 has been fixed.

The following enhancements were made in iWitness Version 1.2.2:

  • Image Preview via tooltips on Thumbnails; hover over Thumbnail for enlargement.
  • Optionally depress the keyboard "Enter" key to save the Scale Distance, within the Scale Dialog Box; no longer necessary to click the "Apply" button.
  • Keyboard Right & Left Arrows toggle the points in Edit\Review Mode.
  • Screen Grab (G icon in tool bar) saves the workspace to a JPEG image.
  • Sometimes Reference Point Labels turned "red". This has been fixed.

The following enhancements were made in iWitness Version 1.2.1:

  • An important camera calibration issue resolved.
  • Critical software security fix.

The following enhancements were made in iWitness Version 1.2:

  • Ability to generate polyline curves and edges from non-corresponding image points.
  • Photo-realistic texturing of 3D objects now possible, with export in VRML format.
  • Standard errors of object point coordinates now listed in point dialog box.
  • Re-worked format for expanded hot-key list.
  • Automatic pixel size adjustment for cameras used at less than maximum resolution.
  • Ability to toggle scale bar on and off in the image and 3D views, using the S key.
  • Ability to toggle lines on and off in the image and 3D views, using the D key.
  • Ability to change point ID size, using Ctrl key combined with scroll wheel mouse.
  • Active 3D point remains highlighted yellow, after "open all photos that see..."n" is invoked.

The following enhancements were made in iWitness Version 1.107.3:

  • Line length of highlighted line shown on screen & number of image, also shown when camera icon is clicked in the 3D View.
  • Minor fixes\enhancements were incorporated in V1.107.3.

The following enhancements were made in iWitness Version 1.107.2:

  • The installation procedure has been improved in V1.107.2.
  • The iWitness User Manual has been updated.

The following minor enhancement has been made in iWitness Version 1.107.1:

  • Now present in 1.107.1 is improved image viewing and 3D view tiling and automatic re-sizing when windows are opened or closed.

A brief summary of the main enhancements in V1.107 is as follows:

There were many both significant and small enhancements and improvements made to iWitness for the 1.107 release. Only those that would be conspicuously noted by the operator are listed.

  • There is now an additional means to set the pair of images to be referenced.
  • An orientation progress indicator has been added.
  • Image panning is now possible using the central mouse button/wheel.
  • The default cursor is now the Select cursor.
  • Project units can now be changed at any time.
  • Object point axes can be displayed in the image views.
  • Point descriptions can be now be applied to multiple points at the time of referencing.
  • There is now a point dialog box.
  • A new Hotkey, H, has been added to toggle point labels for referenced points on and off.
  • Double-clicking on a camera in the 3D view will open the corresponding Image View.
  • Alt-Right Click in the Image View does a fit-to-screen.
  • A new approach to Coordinate Transformation with Control Points.

A brief summary of the main enhancements in V1.106 is as follows:

  • Provision of a guiding line in referencing mode.
  • Inclusion of a station orientation dialog.
  • Image thumbnails 'painted' onto the camera backs in the 3D view.
  • 30 new digital cameras added to the global database (total is now approx. 700).
  • All these features are described in "iWitness Updates.pdf" in the C:\Program Files\iWitness\docs folder.

A brief summary of the main enhancements in V1.105 is as follows:

  • An improvement within the initial image orientation process reduces the occurrence of 'bad intersections' in the early referencing of image combinations which have weak geometry (e.g., near planar target arrays).

A brief summary of the main enhancements in V1.104 is as follows:

  • An update to the global database entry for the Nikon D100 camera used in the Demo Project was incorporated.

A brief summary of the main enhancements in V1.103 is as follows:

  • Color Scanning Adjustment for coded targets. The process of ‘thresholding’ the images to separate the colored dots from the black background may not recognize all coded targets in instances where the images are under- or overexposed. In such instances the user can manually adjust the color scanning setting in order that the target recognition is enhanced.
  • Brightness control for image display. It is possible to adjust the brightness of the display for an image by positioning the cursor over the image and simply using the up and down arrows on the keyboard.
  • Ability to delete points by highlighting blue ‘predicted’ points in Review Mode. Referenced object points can be deleted by highlighting ‘predicted’ points (blue labels) and then right-clicking and selecting delete point(s).
  • Ability to toggle display of labels of marked and referenced points on and off. The H key can be used to toggle point labels of marked (red) and referenced points (green) on and off in the image display.
  • Writing project summary data to a text file. An additional option, namely SAVE, has been added to the Summary (yellow S menu button). This writes the summary to a text file (e.g. project_ name.txt) which can be edited or printed as required.
  • Zoom-window now activated with either Y or Z key. In order to accommodate the fact that on German-language keyboards, the Z & Y keys are interchanged, both these keys can now be used to activate the Zoom window. This allows the operator to choose the key next to the Shift and Ctrl keys.
  • Multi-select of image thumbnails when changing the camera. The user may now multi-select image thumbnails when reassigning the camera for a selected subset of images. Previously, images were reassigned to a new camera, via the Change Camera command, one at a time.

A brief summary of the main enhancements in V1.102 is as follows:

  • iWitness Updates PDF. The iWitness Updates for V1.102 is present in the C:\Program Files\iWitness\docs folder after executing the installation procedure. The PDF discusses the enhancements in more detail.
  • The globalcameras.dat has been enhanced to display new camera models with the cameras now in alphabetical order.  Additionally, the pixel size information is now displayed for all noted cameras, where they are recognized when selecting them via the Camera parameters dialog box.
  • A graphical display of radial and decentering distortion profiles is now present in the Camera parameters dialog box, when clicking the buttons for Details and Show distortion curves.
  • Ability to invert the 3D graphics display (ie white background) for easier printing. Additionally, the color button can be used to change the color of point symbols to enhance readability.
  • Extension of printout to include camera parameters. When invoking the Summary button (the yellow S), the user will now note that a separate page of camera data is output for each project camera. This page lists the essential camera characteristics as well as the calibration values for the project camera(s).

A brief summary of the main enhancements in V1.101 is as follows:

  • Automatic Camera Calibration. iWitness is now capable of fully automatic camera calibration using specially designed ‘coded’ targets. The image-measuring phase of the camera calibration is completely automated. The coded targets can be purchased as an add-on product to the iWitness software suite. Please contact sales@iwitnessphoto.com for purchasing and ordering information for the iWitness camera calibration codes.
  • The cameras in the Global Database are now presented as a Read Only dialog box. The Global Database can be downloaded at any time from within iWitness. The user selects Edit|Camera database…|Global and then clicks the Auto Update box. So long as the user is on-line, the updated version of the Global Camera Database will be downloaded automatically.
  • Inclusion of inclination angles for the X and Y-axes of the XYZ reference coordinate system.  iWitness is capable of accurately adjusting for axis “tilt” for projects distances that are e.g., 500’ (or 152m).  Testing of iWitness axis inclination and supporting tools Vs an EDM total station has demonstrated measurement agreement between the two methods to .2’ (or 6cm) mean error over 500’ of slope distance.
  • Applying a Z-coordinate target offset. Points can now be projected in the Z-axis to ‘move’ the 3D point(s) a user-defined distance. This feature is especially helpful when features like evidence marker targets and tips of traffic cones need to be projected to a surface for measurement. The Z-coordinate target offset value is exported in DXF, and can be used in CAD diagramming programs.
  • Assigning Network labels. The user can now assign a prefix label in a project network to distinguish it from neighboring networks. This is helpful when importing multiple networks into CAD to delineate the 3D points.
  • Interactive entry of Control Points for Coordinate Transformation. Control Points can now be entered interactively in the Control Point dialog box.
  • Point Merging. During the Referencing operation, the operator may find that he/she has inadvertently referenced the same point in two groups of two or more images, when only a single point label is desired for the 3D point. The Point Merging dialog box provides a simple method to automatically merge the point groups into a single point label with the clicking of a button.
  • 3D Point Information Dialog. Two new mechanisms are provided which indicate to the user specific information on 3D points. The first of these is a tooltip, which will appear in the Image or 3D View when the cursor is placed over a point for a period of a few seconds. Useful information i.e., Point ID, XYZ and images used, is presented in the Image or 3D View. A second option for displaying 3D point information is via the 3D Point Information dialog. The dialog is accessed by placing the cursor over the point and depressing the “P” key. Alternatively, the same information can access through the 3D Points List by double clicking on the Point ID. Here, the user can change the Point Label (giving it a new 16-character point ID), and also giving the point a forty-character text string descriptor. The revised Point ID and\or added Descriptor will appear in the ASCII TXT file, as well as in the 3D DXF export file.
  • Line Drawing in Reference Mode. Lines can now be applied during the Referencing operation. This feature is particularly useful in marking features such as polygons.

New Hot Keys

i)   As an alternative to the Tile command from the Window Menu, the user can select the hot-key combination SHIFT+T.

ii)  To open the 3D View at any time, select G (the cursor should be positioned within an Image window when G is selected).

iii)  The P key opens the 3D Point Information dialog box for the point for which the tooltip is currently displayed (i.e. for the closest point to the cursor).

iv) In the 3D View, the user can display the field of view of any image in the network by highlighting a camera station and selecting the F key (toggle on or off).

Version 1.101 has the same new features as V1.10, and it also has an update to circumvent a possible shortcoming in the automatic updating of network orientation during referencing.

Special note: V1.09 was not a released version.

Upgrade notes: V1.07 to V1.08

A brief summary of the main enhancements in V1.08 is as follows:

  • A new camera database structure has been implemented, which comprises a Local and a Global camera database. Any camera utilized within an iWitness project is now stored within the Local database, which supports addition of new cameras and deletion of cameras. The Global database is a read-only file comprising details of most commercially available digital cameras. The Global camera database will be kept up to date by Photometrix, and will soon be available for download from www.Photometrix.com.au. The changed procedures that accompany the new camera database structure are provided in Part C2 of the Users Manual.
  • A warning is now provided to the user in instances where he/she needs to adjust the color settings for the display screen.
  • The projection of the blue epipolar lines within the referencing mode has been greatly sped up.
  • A problem encountered with the driver for the dongle has been rectified.

General changes:

  • Upon running the iWitness1.08.exe, a Readme.txt file is extracted to the desktop for review.
  • The iWitness CD media is named "Setup.exe", while the download is named "iWitness1.08.exe". The two files are identical.
  • The AVI Movie #2, released on the iWitness CD has been updated to reflect the changes for the Local and Global camera database.

Upgrade notes: V1.07 to V1.08

The upgrade for iWitness Version 1.08 is freely downloadable by licensed existing users of V1.07. After downloading the 20mb file iWitness1.08.exe, simply double click on this to install the upgrade. The upgrade should be installed ‘over the top’ of the existing iWitness. It is not necessary to remove or save any iWitness files, program or data. The installation will have no impact on your existing iWitness projects. Note that your existing dongle is compatible with the upgrade and the dongle must be installed to subsequently run iWitness V1.08.

A brief summary of the main enhancements in V1.08 is as follows:

  • A new camera database structure has been implemented, which comprises a Local and a Global camera database. Any camera utilized within an iWitness project is now stored within the Local database, which supports addition of new cameras and deletion of cameras. The Global database is a read-only file comprising details of most commercially available digital cameras. The Global camera database will be kept up to date by Photometrix, and will soon be available for download from www.Photometrix.com.au. The changed procedures that accompany the new camera database structure are provided in Part C2 of the Users Manual.
  • A warning is now provided to the user in instances where he/she needs to adjust the color settings for the display screen.
  • The projection of the blue epipolar lines within the referencing mode has been greatly sped up.
  • A problem encountered with the driver for the dongle has been rectified.

General changes:

  • Upon running the iWitness1.08.exe, a Readme.txt file is extracted to the desktop for review.
  • The iWitness CD media is named "Setup.exe", while the download is named "iWitness1.08.exe". The two files are identical.
  • The AVI Movie #2, released on the iWitness CD has been updated to reflect the changes for the Local and Global camera database.

.

Upgrade notes for iWitnessPRO: V1.0 to V2.0

.

New, released 30 May, 2008 refer to Readme.txt upon installation. Includes the software programs XYRectify and Zaraf.

1.01
1) Point rejection criteria improved.

1.02
2) Rejected points are shown as red X's rather than red +'s on images.

1.03 to 1.05
3) Internal testing, not released for distrubution.

1.06
4) Software security fix.

5) Reporting of Total RMS in the 3D points list has been fixed.

1.1
6) B&W passive codes for camera calibration, accessed via the Project Settings dialog. Provides automatic calibration via printed codes.

7) Automated network stitching, accessed via "Import projects for linking" under the File menu.

8) XYRectify & Zaraf (located on the CD) can now be launched from the File menu in iWitness. These programs are provided on the iWitnessPRO CD.

9) New menu choice to open the current working folder, accessed via Window | "Open Working Folder."

10) New file extension ".iwpro."

1.1.1
11) Improvements to the B&W passive code feature for camera calibration.

12) Thumbnail files (.thumbnail3) now stored in folder sub-directory.

13) Right-click menu option to access information dialog for a selected 3D point.

2.0

14) Triplet Offet Targets.

15) Same enhancements included as noted above (in iWitness V2).

 Back to top